№ 11283 (Уровень: Базовый)
(М. Ишимов) Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну из куч (по своему выбору) два камня или увеличить количество камней в куче в пять раз. У каждого игрока есть неограниченное количество камней, чтобы делать ходы. 
Игра завершается в тот момент, когда суммарное количество камней в кучах становится не менее 342. Победителем считается игрок, сделавший последний ход, т.е. первым получивший суммарно в кучах из 342 камней или больше. 
В начальный момент в первой куче было 11 камней, во второй куче – S камней; 1 <= S <= 325.
Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.
Известно, что Ваня выиграл своим первым ходом после неудачного хода Пети. Укажите минимальное значение S, когда такая ситуация возможна.

Задание 20.
Для игры, описанной в задании 19, найдите два таких минимальных значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:
- Петя не может выиграть за один ход;
- Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.
Найденные значения запишите в ответе в порядке возрастания.


Задание 21.
Для игры, описанной в задании 19, найдите минимальное значение S, при котором одновременно выполняются два условия:
–    у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;
–    у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом. 
Если найдено несколько значений S, в ответе запишите наименьшее из них.

def f(s1,s2,m):
    if s1+s2>=342: return m%2==0
    if m==0: return 0

    h=[]
    h.append(f(s1+2,s2,m-1))
    h.append(f(s1*5,s2,m-1))
    h.append(f(s1,s2+2,m-1))
    h.append(f(s1,s2*5,m-1))
    #return any(h) if (m-1)%2==0 else any(h)
    return any(h) if (m-1)%2==0 else all(h)
print('19',[s for s in range(1,326) if f(11,s,2)])
print('20',[s for s in range(1,326) if not f(11,s,1) and f(11,s,3)])
print('21',[s for s in range(1,326) if not f(11,s,2) and f(11,s,4)])